Weird Issues And Crashes With Multiboxing

Language: JP EN DE FR
New Items
users online
Forum » Windower » Support » Weird issues and crashes with Multiboxing
Weird issues and crashes with Multiboxing
Server: Asura
Game: FFXI
user: winger
Posts: 7
By Asura.Mystikangel 2020-01-21 12:08:45
Link | Quote | Reply
Hey everyone, first thing I want to say is that the addon/windower devs are amazing. I am so impressed that it works as well as it does.

I am here to seek advice on things to try for troubleshooting an issue. When I dualbox in busy environments such as Domain Invasion or even WKRs, my game becomes unstable. It's gotten to the point where I crash on my main character after every Domain Invasion. My problem has not been reproduced single boxing. I'll try my best to describe how the issue presents itself below:
  • I'll be humming along in a domain invasion, when suddenly I get a huge FPS drop on one of my characters. We're talking 10 or less FPS.

  • Right after the FPS drop on that character, the contents of the chat window start flickering and disappear entirely for lengths of time. The treasure pool, inventory and NPC dialog menus - all of the text disappears.

  • Sometimes the framerate returns to normal for a brief moment. when this happens, text is again readable. After 2-10 seconds the problem returns.

  • 100% of the time where I start seeing this problem, the next time I zone, the zone fails to load. I can't move. Sometimes it's recoverable if i log out and back on, but most of the times when I log off an back on, it crashes. I found another person describing a similar problem from dualboxing and this is their screenshot. Their issue was bitdefender and I've already made the AV exclusions in Windows Defender. Note that this is not my screenshot. I'm just attaching it because my problem looks just like this:

My Configuration
  • Windows: Fresh install of Windows 10 1909, 4K monitor at native resolution, 100% display scaling, 2x GTX 980 in SLI mode, User Account Control is configured not to dim the desktop so UAC doesn't crash windower. configured pol.exe and windower.exe to disable fullscreen optimization.

  • Antivirus: Only Windows Defender. Created explicit rules to exclude the entire Windower directory as well as the PlayOnline program files directory. Just in case I also made a rule to explicitly allow pol.exe

  • Windower: UI scaling to 1.5, Super Sampling enabled (so the background resolution is set by windower as 7680x4320 - verified in the registry), bump mapping disabled, gamepad disabled, mip mapping has been tried at values of 0, 1 and 4. I'm using Borderless Window mode and it takes up the full screen on my main character. My second character is launched after I'm in and is launched under a different profile. That profile is the exact same except I run it windowed at 1080p without super sampling.

  • Config Plugin: 60 FPS on main character (the one that crashes), 30 FPS on my alt. Note that I also experience the problem when I launch them both as 30 FPS by specifying the FrameRateDivisor in init.txt.

  • NVidia Control Panel: Under the NVidia Control Panel, Manage 3D Settings, changed the program settings for “All Play-On-line Games (pol.exe)”: Texture Filtering - Quality: High Quality. I've since changed this back to normal quality to troubleshoot.

What I've tried

  • Google, searching the legacy windower forums as well as FFXIAH forums.

  • I've tried using two entirely separate and isolated windower instances. Doesn't seem to make a difference if I'm using profiles in one instance versus two separate windower binaries in separate folders.

  • Launching both instances at 30FPS instead.

  • Been using the Sandbox addon from the start on both windower instances

  • Various performance optimizations: using the config addon to set FootstepEffects to false, set my in-game preferences to show as few characters as possible, set up a ton of filters in BattleMod using filters.xml, disabled weather in-game.

This really feels like a resource constraint issue as I only seem to experience issues when I'm dualboxing both characters in a really busy area.

As this issue has become more and more prevalent on my system, I should note that it has correlated with me making quality improvement changes. For instance, I went from windowed mode with display scaling set at 150% in Windows 10 to borderless windowed mode at 100% display scaling in Windows 10. This means i'm actually displaying 4K but it's probably more taxing on my system. I've also enabled supersampling. This, along with other changes, increased the frequency of my crashes. (from once in awhile to every single domain invasion)

Am I just pushing an old game too hard?

When I crash I get this in my application log: Application Error Event ID 1000
Faulting application name: pol.exe, version:, time stamp: 0x4e3bcddc
Faulting module name: FFXiMain.dll, version:, time stamp: 0x5e049408
Exception code: 0xc0000005
Fault offset: 0x0007152a
Faulting process id: 0xaa0
Faulting application start time: 0x01d5cfff43334845
Faulting application path: C:\Program Files (x86)\PlayOnline\SquareEnix\PlayOnlineViewer\pol.exe
Faulting module path: C:\Program Files (x86)\PlayOnline\SquareEnix\FINAL FANTASY XI\FFXiMain.dll
Report Id: c41c4f2e-0152-4774-9002-ab648fea087b
Faulting package full name:
Faulting package-relative application ID:

I believe the error above is telling me pol.exe itself is crashing instead of windower.

I've enabled error logging and debug logging but I cannot find any logs anywhere in the Windower folder. I will be happy to attach those if I can find them.

Thanks again to everyone in the community improving the quality of life of FFXI - especially the addon and windower devs. It deserves to be appreciated in all its glory and Windower is a huge part of that!

EDIT: Forgot to include my addons - Timers, Sandbox, Config, Eternity, DistancePlus, GearSwap, PetTP, TParty, Trusts. I've also swapped out 4 ROM files with XI View 2.02. This replaces the font, cursor and status icons.
Server: Sylph
Game: FFXI
user: Talym
Posts: 70
By Sylph.Talym 2020-01-21 16:11:02
Link | Quote | Reply
Just spitballing but have you tried disabling SLI or using one of the various DirectX wrapper shims? (DGvoodoo, the Ashita one, etc.) Wondering if there's something funky going on due to the ancient DX path...

Additionally, you may want to set it up to generate crash dumps:

Though, we may need to find someone who has a current copy of the symbols to actually read a crashdump if you get one generated...
Server: Asura
Game: FFXI
user: winger
Posts: 7
By Asura.Mystikangel 2020-01-22 08:41:41
Link | Quote | Reply
I will set up my instance for automatic crash dumps, awesome tip.

I think my issue is stemming from my overambition to enable super sampling. Last night I ran both boxes at 1080 with super sampling turned off - everything else the same - and I had no issue at all.

I'm going to try out dgvoodoo to offload some work to my video cards and go back up to 4K but with super sampling off. I'll go from there.

Thanks for your help Talym.
Server: Phoenix
Game: FFXI
user: Rizzspeed
Posts: 96
By Phoenix.Rizzspeed 2020-01-22 10:34:58
Link | Quote | Reply
the issue with the black environment with only characters showing is usually indicative of using HQ area .dat swaps, with the map crashing. Usually the fix for that is using a smaller file size for said map or reverting to the original file. If the super sampling off fixes your issue then stick with that.
By 2020-01-22 11:32:07
 Undelete | Edit  | Link | Quote | Reply
Post deleted by User.
Posts: 506
By Aerison 2020-01-22 11:36:47
Link | Quote | Reply
That black screen is usually from HD mods, remove them if you have any.
necroskull Necro Bump Detected! [94 days between previous and next post]
Server: Asura
Game: FFXI
user: winger
Posts: 7
By Asura.Mystikangel 2020-04-25 21:45:43
Link | Quote | Reply
The problem was that i had supersampling enabled in Windower4.

Supersampling is fine on 1080p monitors, but when you go to 4K or so, modern systems have a really hard time with the supersampling option.

Turn off supersampling in windower if you run into something like this and you're trying to run at a high resolution.
Log in to post.