Square Enix Dropping Support For SSL 3.0

Language: JP EN DE FR
2010-09-08
New Items
users online
Forum » FFXIV » General » Square Enix dropping support for SSL 3.0
Square Enix dropping support for SSL 3.0
MSPaint Winner
Offline
Server: Excalibur
Game: FFXIV
Posts: 4635
By Ohji Lunartail 2015-07-18 17:17:10
Link | Quote | Reply
 
Quote:
[Important] Important Notice for Square Enix Account Users
In order to strengthen the security of the Square Enix Account system, support for the SSL 3.0 protocol will end on Jul. 22, 2015.

Due to this change resulting in only TLS 1.0, TLS 1.1, and TLS 1.2 protocols being enabled, it is possible that some browser settings may prevent use of the Square Enix Account system.

Please follow the steps below to confirm and configure your browser settings to allow TLS 1.0, TLS 1.1, and TLS 1.2 protocols.


[Affected Services]

・FINAL FANTASY XIV
・The Lodestone
・Mog Station
・FINAL FANTASY XIV: Libra Eorzea
・FINAL FANTASY XIV Forum
・Square Enix Account Management System
・Square Enix Support Center


[Steps to Confirm/Configure Browser Settings]

■Windows
▽Internet Explorer 11
Please update to the latest version.
※If security settings have been configured individually, please enable TLS 1.0, TLS 1.1, and TLS 1.2.

▽Internet Explorer 10 and earlier
1. Open "Internet Options"
(Tools > Internet Options)
2. Open the "Advanced" tab
3. Select the checkboxes for the following items:
・Use TLS 1.0
・Use TLS 1.1
・Use TLS 1.2
※May differ by version

▽Firefox
Please update to the latest version.
※If config settings have been configured individually, please enable TLS 1.0, TLS 1.1, and TLS 1.2.

▽Chrome
Please update to the latest version.
※If config settings have been configured individually, please enable TLS 1.0, TLS 1.1, and TLS 1.2.

■Mac OS X
▽Safari
If you cannot access the above services normally, please update your software and OS X to the latest version.

▽Chrome
If you cannot access the above services normally, please update to the latest version.

■Smartphone
▽iOS Safari
If you cannot access the above services normally, please update your software and iOS to the latest version.

▽All Android browsers
If you cannot access the above services normally, please update your system software to the latest version.

■Game Console
If you are unable to access the above services, please update your game console software to the latest version.
Sony Computer Entertainment systems: System Software Update
Source

edit: if a mod could sticky this or make it more noticable it would be appreciated, cuz im pretty sure something like this is important
Offline
Posts: 41025
By Jetackuu 2015-07-19 08:24:24
Link | Quote | Reply
 
I believe Firefox was supposed to disable that old standard in v34, and considering Google put out a warning in October, I'd bet that Chrome killed it by now too.

So if you use those and can still connect you're probably good.

I use Palemoon and it's been disabled for awhile and I can still connect. There was some site I go to that can't handle the newer type and I'm trying to remember what it was.
Log in to post.