Thf AF Hand Issue

Language: JP EN DE FR
New Items
366 users online
Forum » FFXI » Jobs » Thief » Thf AF hand issue
Thf AF hand issue
Posts: 29
By cureurface 2014-12-28 08:19:48
Link | Quote | Reply
I decided to finish up my tthf af the other day but before I could get started on that I had to finish my ninja tekkos. Once I finished nin hands I went and got on tthf to start the hands but no cs. I went to try for AF body in castle zvahl bailey and it allowed me to get the the body but I don't have the hands active. Once I got the body I went to castle oztroja to get legs but I only got Gil. How can I activate tthf af hands to get my last 2 pieces?

Notes: I had just completed thf feet > nin hands > tried to flag thf hands > chech coffer for body and got it >.tried to flag again > ran to af leg coffer and only got Gil > logged for the holiday > tried to flag again.

Sorry the typing is sloppy I'm on an ipad
Server: Lakshmi
Game: FFXI
user: Eyrhika
Posts: 764
By Lakshmi.Eyrhika 2014-12-28 09:48:59
Link | Quote | Reply
Are you sure you didn't already get them and either stored or dropped them?
Posts: 29
By cureurface 2014-12-28 11:34:51
Link | Quote | Reply
I had as thick as thieves active from 2010ish and I can't complete hands without first completing as thick as thieves. I completed as thick as thieves before I finished up Ninja Tekko (nin hand AF)

I'm thinking it's a glitch to be honest and I'm afraid I may have to redo as thick as thieves but if anyone else has any suggestions I'd love to hear them.

Thank you,
Server: Odin
Game: FFXI
user: Sheelay
Posts: 2816
By Odin.Sheelay 2014-12-28 11:59:33
Link | Quote | Reply
Worst case scenario you can just reset the quest from that npc in Lower Jeuno and start all over.

Edit: Vingijard, (H-9)
Posts: 6380
By Pantafernando 2014-12-28 12:07:27
Link | Quote | Reply
What was your job when you opened castle oztroja coffer?

Are you sure you opened the coffer? Maybe you opened just the chest.
necroskull Necro Bump Detected! [95 days between previous and next post]
Server: Bismarck
Game: FFXI
user: jackx
Posts: 59
By Bismarck.Ronalas 2015-04-02 16:42:03
Link | Quote | Reply
I am having a similar issue with the THF feet. Did all the other quests went to garliage did the bomb took the item to the old guy in mhaura then went to mhigo in windy then to the spot to trade the pickaxe and nothing happens. Can someone assist with advice ? do not really want to reset and do all the quests all over again :(
By 2015-04-02 16:44:06
 Undelete | Edit  | Link | Quote | Reply
Post deleted by User.
Log in to post.