Sometimes Doesn't Equip The Gear

Language: JP EN DE FR
2010-09-08
New Items
users online
Forum » Windower » Spellcast Scripting » Other » Sometimes doesn't equip the gear
Sometimes doesn't equip the gear
Offline
Posts: 762
By Crevox 2014-01-09 09:03:39
Link | Quote | Reply
 
I have spells that just sometimes don't equip the items. I am using Cure as a test in town because I saw it happening with the debuffs. I can cast Cure the majority of the time and it will equip, but if the cures are back to back or I move recently, sometimes it just doesn't equip the midcast set. The same goes for Paralyze or some other spells. I've also had it not swap back to the idle set. Looking at the gear swap info, it says it wants to equip it, but then it just doesn't.

I've tried a longer delay (.8) and I've tried no delay at all. Is this just the nature of it, or is something wrong? Is there something I can do to fix it?

Code
<if spell="Thunder|Slow|Paralyze|Dia II|Gravity|Sleep|Sleep II|Blind|Cure">
	<midcastdelay delay=".3" />
	<equip when="midcast" set="Player Magical" />
	<equip when="aftercast" set="Idle" />
	</if>
 Leviathan.Comeatmebro
Online
Server: Leviathan
Game: FFXI
user: Rairin
Posts: 6052
By Leviathan.Comeatmebro 2014-01-09 09:53:48
Link | Quote | Reply
 
spellcast uses /equip not packets, can only swap the same slot once per second with /equip

if you want accurate swaps for a spell as quick as dia or a t1 nuke, you might need to swap to gearswap
Offline
Posts: 762
By Crevox 2014-01-09 18:28:05
Link | Quote | Reply
 
I switched over to gearswap, thanks. Didn't realize it was just better.
Log in to post.