Another SC Question

Language: JP EN DE FR
2010-09-08
New Items
users online
Forum » Windower » Spellcast Scripting » Other » Another SC question
Another SC question
 Leviathan.Dwb
Offline
Server: Leviathan
Game: FFXI
Posts: 144
By Leviathan.Dwb 2013-03-18 16:30:22
Link | Quote | Reply
 
Hey guys,

I recetly made a bunch of SC's and one thing I am seeing is sometimes if I macro to fast, the gear will get stuck on a set.

For example

I Sneakattack then WS, it gets stuck on WS set.

Anyway to fix this problem? Below is my thf XML (basic i know :D)
 Sylph.Hitetsu
Offline
Server: Sylph
Game: FFXI
user: Hitetsu
Posts: 2617
By Sylph.Hitetsu 2013-03-18 16:38:18
Link | Quote | Reply
 
I doubt your aftercast delays are working, try wrapping them in " " (action type="aftercastdelay" delay="Whatever")
 Leviathan.Dwb
Offline
Server: Leviathan
Game: FFXI
Posts: 144
By Leviathan.Dwb 2013-03-19 10:25:52
Link | Quote | Reply
 
They are working, if I do it without any macros between it works fine.
 Ragnarok.Sekundes
Offline
Server: Ragnarok
Game: FFXI
user: Sekundes
Posts: 4162
By Ragnarok.Sekundes 2013-03-19 11:55:58
Link | Quote | Reply
 
The code should look like this:
Code xml
<action type="aftercastdelay" delay="7" />

I'm not sure how it's working but you might try that first and see if it corrects the issue.

I can try testing it myself once I'm back home but your rules do look like they may need some other changes. For example, if you hit a JA or a WS that's not listed in your rules(anything other than SA TA or Evis), it won't switch back to your TP set but will also cancel your aftercast from the last actions which may be part of the issue you're having. You need to make it so a general aftercast runs, not just after certain actions and autoset(which only runs during changes to your status such as resting, going to idle, going to engaged ect).
Log in to post.